Archive for general

Wrath of the Ice Cream Truck

Posted in WoW Observations with tags , , , on November 15, 2008 by Mark Pannell

When I was a kid, I lived out in the country. My house was surrounded by corn fields. The nearest city was about fifteen miles south of us. Cable didn’t run down our road. No pizza joints would deliver to us either. So, on the rare occurrence that the ice cream truck made it out our way, it was a big… deal! Whatever crops were planted in the field surrounding our house were usually pretty low to the ground in early- to mid-summer, making traffic on country roads visible for a mile. When one of the neighbors spotted the ice cream truck, it was on. Everyone made a mad dash for their mothers and their purses. Visions of crunchy cones, root beer floats, and orange creamsicles haunted us as the mobile sanctuary of dairy delights crept closer and closer to our homes.

Once the truck arrived, we ordered our goodies, then retreated to one of our porches to devour our treats. The first bite, lick, or sip always set the tone for the disappointment that was about to follow. Much like Christmas day, it’s not that the experience wasn’t as good as we expected. Rather, it was exactly what we had expected. I think kids tend to have fantasies that would do Charlie and the Chocolate Factory proud. We all knew exactly what we were getting, but when it failed to be the absolutely mind-blowing experience that no ice cream treat could ever live up to, then it was just an ice cream cone. Or a root beer float. Or a popsicle. But that didn’t stop us from getting ourselves worked up in a tizzy for the next time the ice cream truck made its rural invasion.

To a certain extent, my experience with Wrath has been a lot like the ice cream truck. It didn’t fail to meet my expectations, per se. Rather, the expansion is exactly what I expected it would be. I think there are shortcomings to living in the age of information. The biggest one is that we’re fed so much information, that nothing is left to the imagination anymore. I’ve seen hundreds of pictures, watched dozens of videos, and read dozens of blogs about the latest WoW expansion. By the time I got it installed and loaded up for the first time, it all seemed a little old to me. I think I absorbed too much information prior to the release date. And to be honest, it kind of took something away from the experience. Truth be told, I’ve played WoW for a grand total of one hour since Thursday morning.

While some of the problem is certainly information overload and maybe a bit of being burnt out with the game in general, there’s another factor worth mentioning. I’ve been meaning to do some upgrades on the old WoW console formerly known as my computer. As much as I hate installations and patching, I decided to pull the trigger and pop the hood on the ol’ girl before installing Wrath. I picked up a new graphics card, 2GB more RAM, a 21.5″ widescreen HD LCD monitor, and a new OS drive. When I fired up WoW for the first time, I cranked all of the settings, knowing full well that I had enough horsepower to do so. Imagine my disappointment when the visuals were choppy at best. A quick ctrl+R confirmed that I was topping out at around 25 FPS. I nudged the settings down a bit, but could still muster little more than 35-40 FPS. Turning in place nearly always dropped my framerate back down into the low 20’s. This is the part where I call on you, the readers, for advice. I’ll be scouring Tom’s Hardware and other sites for feedback, but I want to get this resolved quickly. It’s really bothering me and affecting my Wrath experience. LOL. Anyhow, here are my current system specs:

  • AMD Athlon 64 X2 4200+
  • Abit KN9 Ultra Socket AM2 mobo
  • Ultra X2 550W modular PSU
  • 4GB Corsair XMS DDR2-800 (5-5-5-18)
  • Western Digital Raptor 150GB 10,000RPM SATA 3G HDD (OS drive)
  • XFX GeForce 9800 GT 512 MB
  • ViewSonic 21.5″ Widescreen HD LCD @ 1920 x 1080
  • Windows XP Professional SP3

The only possible issues I can see from that setup are the processor and the power supply. I was running a PNY GeForce 7900 GS on a 19″ LCD at 1280 x 1024 before and consistently pulling down 40-50 FPS. I know that the increased resolution has increased the demand on the system, but I would have assumed that the 9800 GT could have more than handled that. Maybe the processor is the bottleneck. It just seems highly unlikely given the poor performance even with the settings all the way down. The other possibility is that the PSU isn’t supplying enough power to the graphics card. Well, it might be the 12V rail, not the total wattage of the PSU that’s the problem. I haven’t looked up the specs on my power supply yet, but again, I doubt that’s the problem either. Trying to eliminate all possibilities, I even uninstalled and re-installed the nVidia drivers three or four times. It’s getting really old. And yes, V-Sync is off. I didn’t drop all of this money to get piss-poor performance. If I don’t get the issue resolved in the next 24 hours, I’m replacing the proc with a 65W AMD Athlon 64 X2 5200+. If that doesn’t work, I’m going to throw a 620W Corsair modular PSU into the mix. If that still doesn’t work, I’m calling XFX and telling them they can kiss my ass. The End.

Advertisements